Chicagoland Area Modern Mopars
Joining our club forum is FREE, so please take a few minutes to register and join us in Chicagoland's best Modern Mopar club on the web!

After joining, you will not only be able to communicate with our members, but other forums will be available for viewing and posting. These include our CAMM Swap section, featuring parts and vehicles for sale in the Chicagoland area, the Knowledge Base, Off Topic Areas and much, much more.

Advertisements will also be disabled for you once you join.

We openly invite you to join our online community and hope to see you posting soon!
Chicagoland Area Modern Mopars
Joining our club forum is FREE, so please take a few minutes to register and join us in Chicagoland's best Modern Mopar club on the web!

After joining, you will not only be able to communicate with our members, but other forums will be available for viewing and posting. These include our CAMM Swap section, featuring parts and vehicles for sale in the Chicagoland area, the Knowledge Base, Off Topic Areas and much, much more.

Advertisements will also be disabled for you once you join.

We openly invite you to join our online community and hope to see you posting soon!


Everything Mopar for the Chicagoland area
 
PortalHomeRegisterLog in

 

 Flowmaster Force 2 issue!

Go down 
4 posters
AuthorMessage
beach
CAMM Member



Location : Bristol, IL.
Points : 4366
Posts : 60
Reputation : 12

Flowmaster Force 2 issue! Empty
PostSubject: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitimeApril 17th 2011, 1:46 pm

I recieved my cat back Force 2 exhaust (part#817405) last thurs. I went to install it and no such luck I had a 6-8 inch gap between the mufflers and tail pipes. WTF? I tried everything to make it work. I finally put my stock exhaust back on. I called flowmaster the the next day and explained my issue. After checking some numbers, they said they must've shipped me a challenger "H" pipe, which is shorter. Now they are shipping me the correct one, but I did some measuring, and it seems that it will put my mufflers back to the coupling for the rear axle/drive shaft. I want to call it a U-joint, but it's not. I'd think my issue would be longer tailpipes. What have others seen with how this set up should look. What a buzzkill to be that close to having my exhaust on, only to take it back off! Mad thanks
Back to top Go down
Shawn1112
Founding Member
Founding Member
Shawn1112


Location : Hater Proof
Points : 33354
Posts : 12919
Reputation : 1607

Flowmaster Force 2 issue! Empty
PostSubject: Re: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitimeApril 17th 2011, 6:21 pm

Wish I knew bro. Maybe someone who has a flowmaster cat back could chime in.

_________________
"Dont Talk About It, Be About It"
"Get In Where U Fit In"

Flowmaster Force 2 issue! 1236920_10151644188979537_407418136_n
Back to top Go down
beach
CAMM Member



Location : Bristol, IL.
Points : 4366
Posts : 60
Reputation : 12

Flowmaster Force 2 issue! Empty
PostSubject: Re: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitimeApril 17th 2011, 9:23 pm

Thanks. I guess if knowone has had this issue, I'll just have to see when I get my new H pipe. I'm more worried about clearance issues. I suppose I could run the short H pipe with just mufflers and turned downs on them! That would sound awesome for about a day, till I went nuts!
Back to top Go down
moros323
CAMM Pro
moros323


Location : Chitown western burbs
Points : 4579
Posts : 311
Reputation : 12

Flowmaster Force 2 issue! Empty
PostSubject: Re: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitimeAugust 25th 2011, 2:08 am

Return it and get Magnaflow!
Back to top Go down
HemiMag
CAMM All-Star
HemiMag


Location : Chitown Burbs,IL
Points : 8680
Posts : 2784
Reputation : 334

Flowmaster Force 2 issue! Empty
PostSubject: Re: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitimeAugust 25th 2011, 11:18 am

Yes they did send you a Challenger H pipe. Once
They ship the correct one it should be ok
Back to top Go down
beach
CAMM Member



Location : Bristol, IL.
Points : 4366
Posts : 60
Reputation : 12

Flowmaster Force 2 issue! Empty
PostSubject: Re: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitimeAugust 25th 2011, 11:47 am

Problem has been resolved. This all happened back in April! I'm very happy with the sound. The only issue that I'm not happy with is how the tailpipes lined up. They are slightly uneven. I've adjusted a few times and will eventually get them perfect. Thanks.
Back to top Go down
Sponsored content





Flowmaster Force 2 issue! Empty
PostSubject: Re: Flowmaster Force 2 issue!   Flowmaster Force 2 issue! I_icon_minitime

Back to top Go down
 
Flowmaster Force 2 issue!
Back to top 
Page 1 of 1
 Similar topics
-
» Flowmaster Question?
» VIDEO OF MY FLOWMASTER 40'S
» Flowmaster 44 series mufflers only
» JBAs or Flowmaster Catback?
» Electrical issue

Permissions in this forum:You cannot reply to topics in this forum
Chicagoland Area Modern Mopars :: The Garage :: Exhaust-
Jump to: