Chicagoland Area Modern Mopars
Joining our club forum is FREE, so please take a few minutes to register and join us in Chicagoland's best Modern Mopar club on the web!

After joining, you will not only be able to communicate with our members, but other forums will be available for viewing and posting. These include our CAMM Swap section, featuring parts and vehicles for sale in the Chicagoland area, the Knowledge Base, Off Topic Areas and much, much more.

Advertisements will also be disabled for you once you join.

We openly invite you to join our online community and hope to see you posting soon!


Everything Mopar for the Chicagoland area
 
PortalHomeRegisterLog in

Share
 

 Battery is dead......AGAIN!

Go down 
AuthorMessage
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 9:28 am

I havent driven my Charger since Sunday morning and today I went to my garage to get my Charger so I can wash it and the battery was completely dead. No power whatsoever. I get my battery box and hook it up to my battery and what do ya know, my fucking halos come on. My halos come on by themselves every once in a while when they get interference from a radio signal (I have them hooked up to a wireless switch). So I guess something made them come on while my car was in the garage and they stayed on for a few days which completely drained the battery. I think I am going to disconnect them from the power source and only reconnect them when I go to car shows.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
Shawn1112
Founding Member
Founding Member
Shawn1112

Location : Hater Proof
Points : 32286
Posts : 12875
Reputation : 1605

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 9:34 am

Put them on a kill switch. Take the main power wire, cut it and connect a switch to each side that was cut.

_________________
"Dont Talk About It, Be About It"
"Get In Where U Fit In"

Battery is dead......AGAIN! 1236920_10151644188979537_407418136_n
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 9:41 am

Shawn1112 wrote:
Put them on a kill switch. Take the main power wire, cut it and connect a switch to each side that was cut.

Yeah I was thinking that. Or I might get a waterproof Male and Female connector then just unplug them when im not using them.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
irishrt5.7
CAMM All-Star
irishrt5.7

Location : Ingleside
Points : 19759
Posts : 3795
Reputation : 705

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 9:55 am

Dude your car has some issues w/ power... do you have something running constantly that shouldnt be???
Back to top Go down
Shawn1112
Founding Member
Founding Member
Shawn1112

Location : Hater Proof
Points : 32286
Posts : 12875
Reputation : 1605

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 10:01 am

irishrt5.7 wrote:
Dude your car has some issues w/ power... do you have something running constantly that shouldnt be???
ya, your dildo that you left plugged in to his car!

_________________
"Dont Talk About It, Be About It"
"Get In Where U Fit In"

Battery is dead......AGAIN! 1236920_10151644188979537_407418136_n
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 10:04 am

irishrt5.7 wrote:
Dude your car has some issues w/ power... do you have something running constantly that shouldnt be???

Yes the halos turning on by themselves. I have left my car parked for over a week before (after I installed the new battery) and then it started up with no problems at all. I guess its because the halos didnt get any interference and werent on all week draining the battery. A few months ago, I went to get my car out of the garage and the halos were on. I guess it was only for a few hours though because it started right up. But that was proof enough that the halos do come on by themselves while parked in the garage. They come on once in a great while when im driving too.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 10:04 am

Shawn1112 wrote:
irishrt5.7 wrote:
Dude your car has some issues w/ power... do you have something running constantly that shouldnt be???
ya, your dildo that you left plugged in to his car!

ZING!

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
irishrt5.7
CAMM All-Star
irishrt5.7

Location : Ingleside
Points : 19759
Posts : 3795
Reputation : 705

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 10:12 am

Shawn1112 wrote:
irishrt5.7 wrote:
Dude your car has some issues w/ power... do you have something running constantly that shouldnt be???
ya, your dildo that you left plugged in to his car!

Bro that was urs its under the center council i put it there when we changed your "pink thingy" lol
Back to top Go down
HiPwr
Moderator
Moderator
HiPwr

Location : Earth
Points : 19551
Posts : 3498
Reputation : 1463

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 10:42 am

Ah, halos. Such a wonderful mod. nanner
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 11:16 am

HiPwr wrote:
Ah, halos. Such a wonderful mod. nanner

Lol its not the halos' fault its the cheap wireless switch that I have them hooked up to.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 5:31 pm

Well I charged the battery for about an hour and it started right up. The voltage on the EVIC read 13.8-14V when the car was running. I drove it about a block from my garage to my fathers garage. Parked it and washed it. 5 hours later I go to move it out of my fathers garage and the fucker wont start again. Battery has juice but not enough to turn over. This is a BRAND NEW battery. Brian you might be right, something is drawing juice that I dont know about. None of my lights were on so I know they didnt drain anything. My radar detector was unplugged since this morning so I know thats not it either. The only thing I can think of is my hidden GPS locator but it is so small that I doubt that can drain much juice from the battery, not to mention that it was turned off. Im charging it again as I type this so hopefully I can get it started and do some testing.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
firestartr420
CAMM All-Star
firestartr420

Location : Niles, Illinois
Points : 6896
Posts : 2314
Reputation : 292

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 5:38 pm

Perhaps your alternator could be starting to fail... not charging the battery while the engine is running, but still producing enough to keep the car running... i don't have the EVIC, but i do have a voltage reading on my radar, and mine, while running, usually runs about 14.3-14.4v, not a whole lot more than yours but perhaps just enough to keep the car going but not charge at the same time...
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 6:19 pm

firestartr420 wrote:
Perhaps your alternator could be starting to fail... not charging the battery while the engine is running, but still producing enough to keep the car running... i don't have the EVIC, but i do have a voltage reading on my radar, and mine, while running, usually runs about 14.3-14.4v, not a whole lot more than yours but perhaps just enough to keep the car going but not charge at the same time...

That makes sense. I was thinking alternator too but I dont hear any whine from it when the engine is running. I was going to check that as soon as I get the car running again. Thanks.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
firestartr420
CAMM All-Star
firestartr420

Location : Niles, Illinois
Points : 6896
Posts : 2314
Reputation : 292

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 7:03 pm

the alternator won't always whine if something is going wrong... the whine would usually come from the bearings going bad... but it there is something in the windings, you wouldnt notice it. Lets hope too that it isnt an issue with the charging system in the computer. If im not mistaken, the computer regulates alternator output and battery charging, to eliminate the occasional overcharge and things that would cause the battery's to explode... If you find the alternator output is sufficient, and can't find any other source for a power draw, you might want to then have a look at the computer... Good thing its a dead battery and not an exploded one, like what recenly happened to my friend's 07 Mustang while at the track... His computer caused his battery to overcharge and explode, ozzing acid all over the wheel well under the hood, stripped the paint and everything.... Ford did warranty it though, complete with fresh paint and everything...
Back to top Go down
HiPwr
Moderator
Moderator
HiPwr

Location : Earth
Points : 19551
Posts : 3498
Reputation : 1463

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 7:27 pm

Do cars have voltage regulators anymore? Dead battery used to mean battery, alternator, or voltage regulator.
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeAugust 27th 2010, 8:21 pm

I started it up again and it ran fine. The alternator is charging at a steady 14V. I went for a 15 minute drive to make sure the battery got a good charge, shut it off and restarted and it cranked up fast. I will see what happens in the morning.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
The Black Stig
Supporting Vendor
The Black Stig

Location : Lakemoor
Points : 4379
Posts : 557
Reputation : 103

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeSeptember 15th 2010, 9:14 pm

will if you have a multimeter here is an easy to check way to check the electrial system

To test the battery go ahead and clear off the surface charge buy leaving the headlights on for about one minute, let it stand for 5 minutes than measure at the TERMINALS with a multimeter should be 12.6v or higher. leave it connected and watch to see if the voltage drops.

To test the charging system Start and let the car run, measure the voltage at the battery in th trunk at the termnals, it should be around 14.4V IMHO down to 14.2v is allowable. however under the hood at the posts it should be 14.4V Solid if not clean terminals, if not again you have an issue.
Back to top Go down
liljoejoe54
Moderator
Moderator
liljoejoe54

Location : Chicago
Points : 21401
Posts : 4221
Reputation : 848

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeSeptember 15th 2010, 11:21 pm

The Black Stig wrote:
will if you have a multimeter here is an easy to check way to check the electrial system

To test the battery go ahead and clear off the surface charge buy leaving the headlights on for about one minute, let it stand for 5 minutes than measure at the TERMINALS with a multimeter should be 12.6v or higher. leave it connected and watch to see if the voltage drops.

To test the charging system Start and let the car run, measure the voltage at the battery in th trunk at the termnals, it should be around 14.4V IMHO down to 14.2v is allowable. however under the hood at the posts it should be 14.4V Solid if not clean terminals, if not again you have an issue.

Thanks alot bro. I did all that already and the battery (which is only a couple months old) is fine as well as the alternator. It was my damn voltage regulator for my halos that was draining the shit out of my battery. The regulator is on all the time so thats why it drained the battery. I disconnected it and now if I leave my car for a couple days, it still starts right up.

_________________
Battery is dead......AGAIN! Liljoejoe54-1

As I lay rubber down the street, I pray for traction I can keep, but if I spin and begin to slide, please dear god protect my ride. Amen.
Back to top Go down
The Black Stig
Supporting Vendor
The Black Stig

Location : Lakemoor
Points : 4379
Posts : 557
Reputation : 103

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeSeptember 15th 2010, 11:27 pm

will atleast you got it fixed
Back to top Go down
Illinois Chaos
CAMM All-Star
Illinois Chaos

Location : in the other lane
Points : 12205
Posts : 5492
Reputation : 1198

Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitimeSeptember 15th 2010, 11:58 pm

Shawn1112 wrote:
irishrt5.7 wrote:
Dude your car has some issues w/ power... do you have something running constantly that shouldnt be???
ya, your dildo that you left plugged in to his car!

ROTFLMFAO!!!!!
Back to top Go down
Sponsored content




Battery is dead......AGAIN! Empty
PostSubject: Re: Battery is dead......AGAIN!   Battery is dead......AGAIN! I_icon_minitime

Back to top Go down
 
Battery is dead......AGAIN!
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Chicagoland Area Modern Mopars :: The Garage :: Electronics-
Jump to: